Shotime: Loucura do Dia !!
Submarino: WOW!!
PlanilhasGoogle.site
Documentos Google
Apresentações Google
Google Chrome
Microsoft-Excel - Ricardo-Horta.site
Microsoft-Word - Ricardo-Horta.site
Microsoft PowerPoint
Eu
VisualBasic.site
Playlist YouTube Ricardo Horta
Links Interessantes

PlanilhasGoogle.site
Inserir Fórmula 2.0

Na coluna A, estão os produtos.
Na coluna B, estão as vendas de cada produto.
Formula Matricial
Em C:2, você quer somar o total das vendas,...
Formula Matricial
... que estão na coluna B.
Formula Matricial
Não importa se todas as células estão preenchidas.
Por isto, você denominou Soma Parcial.
Formula Matricial
Já em D:2, o papo é outro.
Nela, a soma só será feita, quando todas as células da coluna B
estiverem preenchidas.
A lista de produtos é extensa.
Verificar se a coluna B está preenchida não faz parte do seu objetivo.
Por isto, D:2 exibirá o total somente quando a venda de todos os
produtos estiver lançada.
Formula Matricial

Congelar linhas

Vamos congelar as 2 primeiras linhas e mantê-las sempre visíveis.
Ficará mais fácil acompanhar as totalizações.
Selecione A:3.
Formula Matricial
Clique em Visualizar / Congelar / 2 linhas.
Formula Matricial
Uma linha tênue será exibida abaixo da linha 2.
Formula Matricial
Você navegará pela planilha, utilizando a barra vertical e as linhas 1
e 2 permanecerão visíveis.
Formula Matricial

Soma Parcial

Selecione C:2.
Formula Matricial
Digite a fórmula =B3:B18 e tecle ENTER.
A soma parcial será feita, corretamente.
Formula Matricial

Fórmula Matricial

Selecione D:2.
Formula Matricial
Digite a fórmula
=SE(E(B3:B18>0);SOMA(B3:B18);"")
E Não tecle ENTER.
Finalize com CTRL + SHIFT + ENTER.
É assim que você termina uma fórmula matricial.
Formula Matricial
D:2 está vazia, porque nem todas as células estão preenchidas.
Veja.
=SE(E(B3:B18>0);SOMA(B3:B18);"")
A soma só será efetuada se o intervalo B3:B18 estiver preenchido.
E isto é ótimo!
Formula Matricial
A sua planilha tem centenas de produtos.
Você não utilizará o seu tempo, pesquisando se há alguma célula
em branco.
Formula Matricial
Agora, vamos ao teste final.
Preencha todas as células do intervalo B3:B18.
Formula Matricial
D:3 exibirá o resultado final.
Formula Matricial
Para download do Tutorial, clique aqui


PlanilhasGoogle.site
Documentos Google
Apresentações Google
Google Chrome
Microsoft-Excel - Ricardo-Horta.site
Microsoft-Word - Ricardo-Horta.site
Microsoft PowerPoint
Eu
VisualBasic.site
Playlist YouTube Ricardo Horta
Links Interessantes


Amazon: Livros Infantis


www.planilhasgoogle.site
Autor: Ricardo Horta - Direitos adquiridos - 2017