Shotime: Loucura do Dia !!
Submarino: WOW!!
PlanilhasGoogle.site
Documentos Google
Apresentações Google
Google Chrome
Microsoft-Excel - Ricardo-Horta.site
Microsoft-Word - Ricardo-Horta.site
Microsoft PowerPoint
Eu
VisualBasic.site
Playlist YouTube Ricardo Horta
Links Interessantes

PlanilhasGoogle.site

Função PROCV

Em A:2, você quer informar o código,...
Planilhas Google - Função PROCV
... que será pesquisado em uma planilha chamada Cadastro.
Código encontrado, a função deverá retornar o nome, cadastrado
na coluna B,...
Planilhas Google - Função PROCV
... para a célula B2.
Planilhas Google - Função PROCV

Qual função utilizar?

A nossa velha conhecida PROCV.
Vamos lá.
Em B:2, digite =PROCV(A2;Cadastro!A1:B6;2;Falso)
A:2 é a célula que receberá o código.
Cadastro!A1:B6 é o intervalo de dados na planilha Cadastro com os
códigos e os nomes, que serão pesquisados.
O parâmetro 2 define qual coluna retornará o nome.
Planilhas Google - Função PROCV
O nome está gravado na 2a. coluna, óbvio ululante.
E, finalmente, com o parâmetro Falso, você informa ao Excel que
PROCV deve procurar pelo valor exato.
Observe, que, neste momento, a função está retornando erro.
É porque o código ainda não foi digitado.
Planilhas Google - Função PROCV
Informe o código válido e a função retornará o nome, corretamente.
Planilhas Google - Função PROCV
Planilhas Google - Função PROCV
Para evitar a exibição do erro, quando A:2 estiver vazia,...
Planilhas Google - Função PROCV
... altere a fórmula.
Você pode evitar este tipo de mensagem com a ajuda da função
SEERRO.
A fórmula ficará assim:
=SEERRO(PROCV(A2;Cadastro!A1:B6;2;Falso);"")
Neste caso, código não encontrado, a mensagem não será exibida.
O campo Nome ficará vazio.
Planilhas Google - Função PROCV
Faça o teste.
Código encontrado, nome retornado.
Planilhas Google - Função PROCV

Outra opção

Você pode exibir uma mensagem em vez de o campo nome ficar
vazio.
Clique em B:2 e altere a fórmula.
=SEERRO(PROCV(A2;Cadastro!A1:B6;2;Falso);"Infome o código.")
Planilhas Google - Função PROCV
Se você não digitar o código ou...
Planilhas Google - Função PROCV
... informar um código inexistente na tabela, será exibida aquela
mensagem.
Planilhas Google - Função PROCV
A pesquisa será feita, corretamente.
Planilhas Google - Função PROCV


PlanilhasGoogle.site
Documentos Google
Apresentações Google
Google Chrome
Microsoft-Excel - Ricardo-Horta.site
Microsoft-Word - Ricardo-Horta.site
Microsoft PowerPoint
Eu
VisualBasic.site
Playlist YouTube Ricardo Horta
Links Interessantes


Amazon: Livros Infantis


www.planilhasgoogle.site
Autor: Ricardo Horta - Direitos adquiridos - 2017